AnsweredAssumed Answered

Start Process Instance from REST Error Form

Question asked by naveenv449 on Aug 16, 2018
Latest reply on Aug 20, 2018 by mdtabrezmca

Hi All,

 

There is one urgent issue.. I am trying to hit the Activiti REST call to start the Process Instance. When I hit the Process Instance, it shows that the instance is created and task is assigned to next user. But No form is displayed and it shows error in the page as below.

 

Could someone help me on this?

 

My Input 

{
"processDefinitionId":"GBNewBusinessRenewals:1:17535",
"variables": [
{"name":"insuredname", "value":"lola"},
{"name":"underwritername", "value":"Mike"},
{"name":"foureyeapproval", "value":"true"},
{"name":"documentcomparison", "value":"true"},
{"name":"resreview", "value":"true"}
]
}

And my Output:

{
"id": "20019",
"url": "http://localhost:8080/activiti-rest/service/runtime/process-instances/20019",
"businessKey": null,
"suspended": false,
"ended": false,
"processDefinitionId": "GBNewBusinessRenewals:1:17535",
"processDefinitionUrl": "http://localhost:8080/activiti-rest/service/repository/process-definitions/GBNewBusinessRenewals:1:17535",
"processDefinitionKey": "GBNewBusinessRenewals",
"activityId": null,
"variables": [],
"tenantId": "",
"name": null,
"completed": false
}

 

Error Screen shots

 

And I took the URL from the console and tried to hit it.. It shows the below error:

HTTP Status 500 - Request processing failed; nested exception is org.activiti.form.engine.ActivitiFormException: No submitted form could be found

 

 

Then I tried creating an app with one level approval with a simple form with 2 text fields and try to hit it with REST API. I get the same error.

 

Any Help please.. Alfresco Official Greg Harley Bassam Al-Sarori

Thanks in Advance

Naveen

Outcomes