AnsweredAssumed Answered

Alfresco CE 5.2 File Upload Limit

Question asked by gcaldani on Sep 3, 2018
Latest reply on Sep 3, 2018 by gcaldani

Hi,

i have installed alfresco community 5.2 on a CentOS 7 system using the installer: alfresco-community-installer-201707-linux-x64.bin

Everything seems to work well, except that the system never accept uploading files > 1MB.

I have tried:

 

in <TOMCAT-ROOT>/shared/classes/alfresco-global.properties

I added the line: system.content.maximumFileSize=5368709120

 

in <TOMCAT-ROOT>/shared/classes/alfresco/share-config-custom.xml

I verified that the tag <file-upload> doesn't contain anything different from the share-documentlibrary-config.xml

I disabled Adobe Flash Player

 

in <TOMCAT-ROOT>/webapps/share/WEB-INF/classes/alfresco/share-documentlibrary-config.xml

there is: <maximum-file-size-limit>0</maximum-file-size-limit>

 

I used the admin user, i created another user with 100 GB quota, i tried to upload files with both admin and ther new user, in my-files and inside a new created Site, i also tried to upload files using webdav but.... the limit is always 1 MB and i'm going crazy.

 

Another strange thing is that if i see the profile settings with admin user, even users have uploaded some stuff, the 'bytes used' field always report 0.

 

At system level i have to say that i changed the default contentStore and contentStore.deleted to use an nfs4 path to another CentOS server, and i use a proxy nginx to reach alfresco with https (certificate is installed into nginx and not into java keystore) so, locally, all the services use their defaults. Localization is italian.

Everything work fine except this problem. Please help me.

Outcomes