AnsweredAssumed Answered

org.activiti.engine.ActivitiWrongDbException: version mismatch: activiti library version is '5.20.0.1', db version is 5.21.0.0 Hint: Set <property name="databaseSchemaUpdate" to value="true" or value="create-drop" (use create-drop for testing only!) in be

Question asked by ncs_lirui on Sep 19, 2018

My activiti library is 5.21.0.0,I have checked 4 times,the version in my maven pom.xml is 5.21.0,I am very sure of that,and the schema.version field in the act_ge_property table is 5.21.0.0 too,but it shows the wrong:org.activiti.engine.ActivitiWrongDbException: version mismatch: activiti library version is '5.20.0.1', db version is 5.21.0.0 Hint: Set <property name="databaseSchemaUpdate" to value="true" or value="create-drop" (use create-drop for testing only!) in bean processEngineConfiguration in activiti.cfg.xml for automatic schema creation

I tried the way to set <property name="databaseSchemaUpdate" to value="true" >,it still report this error,I have no idea of where the activiti library version is '5.20.0.1' comes from,I delete the maven and reinstall it twice,the activiti library in my repository really 5.21.0 and only 5.21.0,please help me.
  

Attachments

Outcomes