AnsweredAssumed Answered

Reverting Word Document breaks Alfresco, showing strage error messages in share

Question asked by jacotec on Oct 11, 2018

Hi,

 

I ran into a strange issue with the Community Edition 6.0. All works very well except when I want to revert a Word Document to an earlier version.

 

I'm editing a Word Document with Word, using the "Edit in Microsoft Office" function in Share. So, Word fires up and I'm editing the document and save it (which creates a new version).

I'm doing 2-3 new versions this way, and then I choose the first of the new versions in the document history and select "Zurücksetzen" (Revert to this version). Alfresco presents the dialog where I can choose between major and minor version. I leave the comment blank and choose "minor version", then I hit OK.

 

As a next step Alfresco presents a Window "Internal Server" error, but it creates the new version.

 

But even worse: Now every time this Word Document is shown, the complete Web Page of Share is corrupted, showing two times the error message:

 

An error has occured in the Share component: /share/service/components/document-details/document-actions.
It responded with a status of 500 - Internal Error.
Error Code Information: 500 - An error inside the HTTP server which prevented it from fulfilling the request.
Error Message: 09110021 Failed to execute script 'classpath*:alfresco/site-webscripts/org/alfresco/components/document-details/document-actions.get.js': 09110020
Server: Alfresco Spring WebScripts - v6.20.0 schema 1.000
Time: 11.10.2018 12:25:17
Your request could not be processed at this time. Please contact your system administrator for further information.

This message appears whenever I visit the particular Word document in share. See Attachment "Alfresco1.jpg"

When I open the "broken" document in share, the alfresco.log throws this error:

 

2018-10-11 12:40:11,788 ERROR [org.springframework.extensions.webscripts.AbstractRuntime] [http-nio-8080-exec-46] Exception from executeScript: 09110004 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js
org.springframework.extensions.webscripts.WebScriptException: 09110004 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js
at org.alfresco.repo.web.scripts.content.StreamContent.execute(StreamContent.java:176)
at org.alfresco.repo.web.scripts.RepositoryContainer$3.execute(RepositoryContainer.java:512)
at org.alfresco.repo.transaction.RetryingTransactionHelper.doInTransaction(RetryingTransactionHelper.java:450)
at org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecute(RepositoryContainer.java:587)
at org.alfresco.repo.web.scripts.RepositoryContainer.transactionedExecuteAs(RepositoryContainer.java:656)
at org.alfresco.repo.web.scripts.RepositoryContainer.executeScriptInternal(RepositoryContainer.java:428)
at org.alfresco.repo.web.scripts.RepositoryContainer.executeScript(RepositoryContainer.java:308)
at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:399)
at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:210)
at org.springframework.extensions.webscripts.servlet.WebScriptServlet.service(WebScriptServlet.java:132)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:292)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:207)
at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:240)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:207)
at org.alfresco.module.aosmodule.service.ContextRootFilter.doFilter(ContextRootFilter.java:93)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:240)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:207)
at org.alfresco.web.app.servlet.GlobalLocalizationFilter.doFilter(GlobalLocalizationFilter.java:68)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:240)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:207)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:212)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:94)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:492)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:141)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:80)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:88)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:502)
at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1152)
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:684)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1539)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1495)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:748)

 

Even worse, in the folder listing in share the page where this word document is listed won't display anymore and quits with the error message:

 

09110025 Failed to execute script 'classpath*:alfresco/site-webscripts/org/alfresco/components/documentlibrary/data/surf-doclist.get.js': 09110024

See attachment "Alfresco2.jpg".

 

The only way to get that fixed is to revert this document back to a version which was before my editing (and which was saved with Alfresco 5.2, if this information helps).

 

Any ideas what's happening here are highly appreciated. It seems I need to turn versioning off if I can't get this under control.

Attachments

Outcomes