AnsweredAssumed Answered

Migration from 5.0 to 6.0.5

Question asked by eee777 on Jan 24, 2019
Latest reply on Jan 31, 2019 by eee777

Hello everyone,

 

I'm trying to upgrade our Alfresco CE from 5.0 to the latest 6. Also i wanted to switch from PostgreSQL to mariaDB. So, i have installed a new CentOS7 instance with Tomcat, mariaDB and nginx as reverse proxy. Alfresco deployment went well and i was able to access the share as well as the admin console. I have moved the alf_data content and migrated the PostgreSQL database from the old instance to mariaDB. Now the issue is that the alfresco service does not start because of the database schema auto-update:

 

2019-01-24 15:25:30,332 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] [localhost-startStop-1] Schema managed by database dialect org.alfresco.repo.domain.dialect.MySQLInnoDBDialect.

2019-01-24 15:25:30,373 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] [localhost-startStop-1] Another cluster node is doing a DB schema initialization or DB update. Waiting for the other node to finish...

2019-01-24 15:25:30,373 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] [localhost-startStop-1] DB lock failed on schema bootstrap. Attempt: 0

2019-01-24 15:25:35,381 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] [localhost-startStop-1] Another cluster node is doing a DB schema initialization or DB update. Waiting for the other node to finish...

2019-01-24 15:25:35,381 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] [localhost-startStop-1] DB lock failed on schema bootstrap.

 

2019-01-24 15:27:30,518 ERROR [org.alfresco.repo.domain.schema.SchemaBootstrap] [localhost-startStop-1] Schema auto-update failed

org.alfresco.error.AlfrescoRuntimeException: 00240000 A long running upgrade was found to be running on another node of the cluster. This node is shutting down.

2019-01-24 15:27:30,519 ERROR [org.springframework.web.context.ContextLoader] [localhost-startStop-1] Context initialization failed

org.alfresco.error.AlfrescoRuntimeException: 00240001 Schema auto-update failed

 

2019-01-24 15:27:30,809 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] [localhost-startStop-1] Stopping 'ContentStore' subsystem, ID: [ContentStore, managed, unencrypted]

2019-01-24 15:27:30,810 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] [localhost-startStop-1] Stopped 'ContentStore' subsystem, ID: [ContentStore, managed, unencrypted]

2019-01-24 15:27:31,456 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] [localhost-startStop-1] Stopping 'Authentication' subsystem, ID: [Authentication, managed, alfrescoNtlm1]

2019-01-24 15:27:31,456 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] [localhost-startStop-1] Stopped 'Authentication' subsystem, ID: [Authentication, managed, alfrescoNtlm1]

 

It's a single instance, there is no cluster or other node. Any suggestions how to fix it? Did i miss something during the migration?

 

Thank you for your time!

Outcomes