AnsweredAssumed Answered

Alfresco Community 6.1 - General Release: 201901 Installation problem

Question asked by chulwoo.lee on Mar 6, 2019
Latest reply on Mar 11, 2019 by chulwoo.lee

Hi 

 

I am trying to install the latest Alfresco 6.1 community version of ECM by manually with distribution.zip.

 

I have read and followed all of the instruction from Installing using distribution zip | Alfresco Documentation , but I am stuck when I started Tomcat. I have triple-checked the installation procedures and tried multiple times with new setup but same issues are coming up. I hope not I am not missing something.

 

I am using Tomcat version 7.0.93, and copy/paste postgresql-42.2.5 from 6.1 community-ga zip file (alfresco-content-services-community-distribution-6.1.2-ga\web-server\lib\postgresql-42.2.5.jar) into TOMCAT_HOME/lib just like stated in the Alfresco documentation. (Installing the Alfresco WARs | Alfresco Documentation )

 

The localhost:8080/alfresco states:

Cannot find Alfresco Repository on this server. (Does this application have access to alfresco-global.properties? Does this application have cross-context permissions?)

 

From the tomcat server log, there is actually an error message  (I am sure most of the error logs are irrelevant so I am attaching the last part which looks like postgresql error) :

------------------------------------------------------------------------

Caused by: org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.)
... 
Caused by: org.postgresql.util.PSQLException: Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
... 
Caused by: java.net.ConnectException: Connection refused: connect

-----------------------------------------------------------------------------

 

I am assuming this is PostgreSQL server issue where postgreSql has not started with Tomcat? so... do I need to install a separate postgreSql in my server and map it in alfresco-global.properties?

 

I am attaching all of the files I have touched during installation to provide as many info as I can.

Please help me fix this problem. Very frustrated.

 

Thank you in advance.

Outcomes