AnsweredAssumed Answered

Patch and Upgrade Question

Question asked by ralphhyatt on Mar 21, 2019
Latest reply on Mar 25, 2019 by ralphhyatt

I'm trying to upgrade Alfresco Enterprise 3.4.14.24 to 4.2.8 and everything works fine except one patch fails. The patch is "patch.htmlNotificationMailTemplates" and the error message is:

 

"Caused by: org.alfresco.service.cmr.view.ImporterException: Path /app:company_home/app:dictionary/app:email_templates/app:notify_email_templates within node workspace://SpacesStore/44a91b68-6a1a-11dd-b2bc-c5d7fa2d5662 found too many locations - the path must resolve to one location"

 

When I navigate to that folder using alfresco I see one file, notify_user.email.ftl.. However, if I navigate to the same folder using share I see five files. All of them have different titles, but two share the same file name, also notify_user_email.ftl. I tried reloading the DB, reinstalling the 3.4.14.24, deleting one of the apparently duplicate files, and then upgrading, but got the same error.

 

Also, I only see the file in one physical location: 

 

/apps/alfresco/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/templates/email/notify_user_email.ftl

 

I am totally new to Alfresco. Any suggestions on what to do would be greatly appreciated.

Outcomes