AnsweredAssumed Answered

Upgrading alfresco 201605 - Cannot find Alfresco Repository

Question asked by zerogreat on May 17, 2019
Latest reply on May 20, 2019 by zerogreat

Hello,

some time i 2016 I have installed Alfresco 201605 on Windows server. Last few days I have really been struggling to upgrade it to some newer version (I have tried 201612 and 201707). Can you please tell me, what am I doing wrong?

 

My checklist:

-stop tomcat

-backup alf_data

-backup postgresql database "alfresco" (using handy backup 8)

-uninstall old alfresco

-install new version (setting the same administrative password as in the old one)

-start postgresql and restore the "alfresco" database

-restore folders contentstore, contentstore.deleted, solr4 and solr4backup from backup to new Alfresco\alf_data (alfresco-global.properties is pointing to this correct alf_data location)

-start tomcat

 

Opening Alfresco in browser then displays error "Cannot find Alfresco Repository on this server. (Does this application have access to alfresco-global.properties? Does this application have cross-context permissions?).

 

When I tried the same procedure to migrate data from 201605 to a newly installed 201605 it worked. But it does not work with newer version. It looks like the contentstore is not recognized by different version than the one I am on.

 

Please advise.

Thank you

Best Regards

Martin

Outcomes